Cachet

Some systems are under maintenance.

Master Repository

Fixed

1 week ago —

The culprit was incompatibility between request arguments within Fastly, and on our origin servers. This has been remedied.

Identified

1 week ago —

The culprit has been identified as related to how the Fastly CDN is interpreting Accept-Encoding headers, notably when served compressed content. We're working on a resolution.

Roughly 1-3% of traffic is impacted. It is only impacting repo metadata fetches, and dnf itself is not impacted - it appears mostly to be impacting various API-like requests from automated systems depending on how the client structures its request headers.

2 weeks ago —

repo.almalinux.org is intermittently serving 501 responses to requests. We are looking into this.

Note: this issue was reported and confirmed on March 3, 2026 but we backdated this issue to represent when the issue began.

Incident UUID 96ec77f9-8554-40d7-85a1-907457bd4cde